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Introduction 

Xtreme takes a traditional animator's approach to Flash animation. You create key 

frames (or 'snap-shots') of your animation through time, and Xtreme automatically 

creates all the in-between frames for you. 

 

Xtreme does not have timelines (which is the approach used by the Adobe Flash 

authoring tool). We feel our approach is far simpler. 

 

  

An example start frame 

  

  
The next key frame has the star shape moved, rotated a 

little, reduced in size, and changed to a different color. 

  

 
Xtreme will create a smoothly animated Flash file automatically creating the 

 in-between frames. This process is traditionally called tweening. 

  

What Flash can and cannot do 
The Flash format does not support some of the advanced effects that Xtreme offers, 

for example complex graduated transparency, feathering, bevels and most of the 

advanced color fill types. 

 

However it does support a range of effects that include simple transparency. So, for 

example, if you fade the star on the 2nd key frame above to be 100% transparent, 

you'll get an animation where the star moves, reduces in size and fades. 

  

 
 The same example, with in-between frames, but employing a transparency too. 

Like Xtreme, Flash is vector graphics based which means you can enlarge objects 

with no loss of detail. It also means Flash files can be very compactąwhich is of 
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course ideal for web download. 

 

To illustrate just how small and compact Xtreme Flash animations can be, the 

previous example animated over one second with 24 frames (so the movie plays at a 

smooth 24 frames per second) creates a Flash file that's only 700 bytes. 

 

The 6 core transformations 
In order to keep Flash files very compact, the types of shape tweening supported by 

Flash is limited to six core transforms: 

1. Moveąyou can move objects from one position to another. 

2. Scaleąyou can enlarge or reduce objects in size. 

3. Squash or skewąyou can squash or skew objects. 

4. Rotateąyou can rotate objects. 

5. Transparencyąyou can adjust the overall (flat) transparency of the objects. 

6. Color transformąyou can change the fill (flat) color of objects. 

  

Note : the above six transform types are absolutely key to all Flash animations. No 

other type of transform is possible for the tweened frames. 

 

If you look at Flash animation examples on the web, you'll find that almost all consist 

of just these effects. Objects fade in and out; they whiz from one position to another. 

They sometimes spin, and often grow or shrink. That's the basis for almost all Flash 

animations, and it's very easy to produce such animations in Xtreme. 
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Because the shape changesąi.e. it morphs from one shape to another, this is not 

possible in Xtreme Flash animations. 

  

Important:   tweening is not like the Blend tool, which can 'morph' from one shape 

to another. To stress the point again: the only things you can do to shapes, text and 

photos in Flash animations are the six core transform types listed above. 

 
 

Transforms 1 to 6 

can be applied to 

all vector shapes 

and text, and 1 to 

5 can be applied 

to photos. 
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What you can't do with Xtreme Flash 
Xtreme is primarily a vector illustration package and is not designed to be an all-

encompassing Flash tool. Instead we feel it brings a new, innovative, very easy to 

understand approach to Flash animation. Combined with Xtreme's acclaimed vector 

drawing tools and slick ease-of-use, it allows you to create really compact Flash 

animations more easily than other tools. 

  

Because of this simplified approach, Xtreme does not support more complex Flash 

features such as scripting (programming), audio or embedded movies. 

  

Additionally, as Flash vector rendering is relatively primitive compared to Xara 

Xtremeĉ¨4there are advanced Xtreme effects that cannot be used in Flash. These are 

detailed in the What Xtreme Features Does Flash Support? section towards the end 

of this chapter. 

 

Initial reading 

The main manual contains more information on: 

 The Name galleryąpage 39. 

 The Frame galleryąpage 203.                   

 Animated GIFsąpage 203. 

  

Core principles 

In your animation you are likely to have some objects that remain static between key 

frames (i.e. no tweening is necessary) and other objects you will want to animate.  

 

To tell Xtreme which objects you want to animate it's necessary to give each object 

a name, which is simply done via the Create New Names button on the Selector tool  

InfoBar. 

 

 
 

An overview of the typical process to create a new animation from scratch, which 

this chapter will guide you through, is this: 

1. Draw your first frame. Name the objects that you want to animate.  

2. Create a new key frame, usually done by copying the earlier frame. 

3. Move and transform the objects as required. 

4. Preview the results. 

5. Repeat steps 2 through 4. 

 

And so you can then build up your animation. 

Xtreme provides an easy one-button way to create new key frames which are a 

copy of a previous frame (see left). The Frame gallery allows you to view any key  
The Copy 

Frame button on 

the Animation  

button bar. 
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frame, and you can adjust the frame order and display period for each key frame. The 

Frame gallery is described in depth later in this chapter. 

  

For those familiar with the animated GIF features of Xtreme (or its predecessors) 

the whole process will be very familiar. The difference is that with Flash files Xtreme 

can automatically create all the tween steps, to produce smoother and much more 

compact animations than animated GIFs can offer. 

  

Note : objects that you want to animate from one frame to another need to have a 

name. All other objects will remain visible, but static, for the display period of the 

frame until the next key frame. So to delete an object from an animation, just delete 

it on the first key frame on which you no longer need it to appear. 

 

Your first animation 

To create a new animation: 

1. Create a new animation document. To do this: 

 Choose File > New > Animation (shortcut Ctrl+ĕ+N). 

 Or click the New Animation  button on the Standard  button bar. 

 
A new document will open, and you will see the animation button bar 

appear that contains some relevant buttons. 

2. Draw a simple black rectangle (like shown in the examples at the beginning 

of the chapter). Give it no fill color. 

3. Draw a simple shape, such as the QuickShape star (but it can be any shape). 

4. Click the Create New Names icon on the Selector InfoBar and name it 

'shape'. 

 
5. Click the Copy Frame button to create your 2nd key frame. 

 
6. Transform the shape as required. You can adjust it using any of the six core 

transforms described earlier in the chapter. 

7. Press the Preview Flash button to see the animation. 

 
 

By default the display period for each key frame is half a second. To produce a longer 

animation, see the Movie Frame Rate and Tween Steps section later in the chapter. 

  

For more complex animations we strongly recommend you display both the Frame 

and Name galleries (described in depth later in the chapter), which can be docked on 

the side of the Xtreme window for ease of access.  
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You are not limited to just one moving object. You can have as many as you like on 

each key frame. And as long as they appear, transformed in some way, on the next 

key frame (and they are each given a unique name) they will animate. 

  

Here is another example. 

 

 
The first key frame has some simple text and a simple shape within a static rectangle. 

  

 
And this is the next frame, where the text has been reduced in size at the 

same time as the star shape has been reduced, re-colored and rotated. 

  

This is how the animation is constructed. 

 

 
In this animation, the text object recedes into the distance 

while at the same time the star shrinks and fades. 

 

 

Key frame 1 

 

 
 

Intermediate 

tween steps 

produced by 

Xtreme Pro 

 

 

 

 

Key frame 2 
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Exporting a Flash file 

To export your animation as a Flash file: 

 Select File > Export and then choose Flash under Save As Type. 

 Or click the Export Animated Flash button. 

 
 

This will save the finished SWF file into the location you choose. 

 

Inserting your Flash animation into a web page 
To view your animation as it would look in a web page, click the Preview Flash 

button to see a browser preview. 

 
 

The preview page will show your finished animation as well as useful information 

¨ªw|4u¨4©|y4u£}¢u©}¤£ĉ¨4x}¢y£¨}¤£¨@4z}¡y4¨}¯y4u£x4y¨©}¢u©yx4x¤¬£¡¤ux4©}¢y¨B 

 

To place your SWF animation into a web page you will need to insert some HTML 

code. Click the View HTML link to get code that you can paste into your web page 

using your preferred HTML editor. 

 

Note:  you must change the SWF filename in the code to match the actual name of 

your exported SWF file. You must also place your SWF file into the same directory 

as your web page for the code to work. While you can place the SWF file in a 

different directory, you will need to change the HTML code accordingly if you do.  

 

The Frame gallery  

To open the Frame gallery choose Utilities > Galleries > Frame Gallery, or click the 

Frame gallery icon on the Galleries toolbar. 

 
 

This shows a list of the key frames in your document. To view any key frame just 

click its name in the gallery. 
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A typical Frame gallery. Frame 2 is selected and thus visible. 

  

The Frame gallery shows frames from the top down, so the first frame is at the top 

and the each new frame you add gets put at the bottom of the list. You can re-order 

frames by dragging them. There are buttons to perform the main operations of 

deleting frames, copying the selected frame (it will always get added to the end) and 

creating new blank frames. The Properties button is very important as it shows the 

Animation Properties dialog which controls many aspects of not just the selected 

frame but the whole animation. 

 

 
The Animation Properties dialog 

 

The All Frames Visible (the eye) and Edit All Frames (the arrow) buttons on the 

Frame Gallery are useful because they allow you to view or edit all frames together, 

one on top of the other. This is particularly useful if you want to select objects that 

are on multiple frames.  

  

Note: when you copy a frame it always copies the selected frame and places it at 

the end. So in order to insert a new frame, say between frames 4 and 5, select frame 

  

The frame order 

is the reverse of 

that in earlier 

versions of Xara 

Xtreme. 

A shortcut to 

display the 

Animation 

Properties dialog 

is to simply 

double-click on a 

frame name in 

the Frame gallery 
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4, click the Copy button, and then drag the new copy from the end to the desired 

position between frames 4 and 5. 

  

Note:  frame names do not matterąand can be anything you like. They do not have 

to be Frame 1, Frame 2 etc. Animations always play the frames in the order top to 

bottom, irrespective of the names. 

 

Copying objects 
You can copy objects from one frame to another in the usual way (i.e. copy the 

content, select the new frame and then paste into the new frame). The Edit > Paste 

in Place option (Ctrl+ĕ+V) is particularly useful when doing this, as this will always 

paste objects back to the exact position they came from but on the new frame. 

  

When you copy an object its name is copied with it. But be careful not to have more 

than one object with the same name on a given frame. Doing so will generate errors. 

 



 

 

11 

 

Release 

Notes 

Photos  

Because Flash files usually consist of vector shapes, and the transforms are relatively 

simple, the files can be very small. Photos and bitmaps can be embedded into Flash 

animations, but unless you are careful it will result in huge animation files. You can 

perform 5 of the 6 core Flash transforms on bitmaps or photos (i.e. you can move, 

scale, squash, rotate, and fade). 

  

Flash files can include both PNG and JPEG images just as .xar files do, and so if you 

keep their size and resolution down you can create acceptably small Flash animations 

with photos. The best way to incorporate photos is to use JPEG images as small as 

you can possibly get away with, and with the maximum compression you can accept. 

  

Fortunately it's easy to save JPEG images from Xtreme, at any size, resolution and 

compression and you even have interactive preview where you can adjust the 

compression and immediately see the result. 

  

If you just drop a JPEG file onto the animation, and resize it, that does not reduce the 

size of the JPEG fileąit only reduces the dimensions (and thus increases the 

resolution). Flash is just like Xtreme in this respectąit will embed the original full 

resolution JPEG image, so you can zoom in. So it's easy to estimate the size of any 

animation containing JPEG photosąit's approximately the sum of the sizes of all the 

embedded JPEG images. (The Bitmap gallery will show you the size of all embedded 

photos or bitmaps). 

 

When tweening bitmaps or photos only one copy of the bitmap is stored in the Flash 

fileąso you can perform transformations of the bitmap with little overhead. In other 

words just because the bitmap appears on frames 1, 2 and 3 of your animation does 

not mean three copies of the bitmap are embedded in the Flash file. 

  

Producing optimized JPEG photos 
To create a smaller JPEG, it's necessary to export it as a new JPEG from Xtreme at 

the required size and compression value, then re-import the now-reduced JPEG. The 

steps are this: 

1. Drop the required JPEG file onto Xtreme. 

2. Resize it to be the size you require in your animation. 

3. Select File > Export (shortcut Ctrl+ĕ+E) and export as JPEG. 

4. In the export preview window, select the Options tab and adjust the quality 

slider as low as you can make it. The file size is shown under the preview.  

5. Export the JPEG. 

6. Drag and drop your new mini-sized JPEG from Windows File Explorer back 

onto the animation document where you intend to use it. This JPEG file will 

be embedded into the Flash file (and the .xar file when you save). 
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Non-JPEG bitmaps 
Other types of bitmap, for example, BMP, TIFF or PNG bitmaps, are usually a lot 

larger and thus less suitable for use in Flash animations (JPEG compression is a lot 

better than PNG). Therefore, when creating a Flash animation, these bitmaps get 

converted to JPEG in order to create the smallest possible file size. 

 

You can control the compression used for this automatic JPEG conversion using a 

slider in the Flash Options tab of the Animation Properties dialog. The usual 

compression value is 75%, but you can vary the quality, preview the animation and 

quickly see the quality and size savings. Note: this only affects automatically 

generated JPEG bitmaps. JPEG files that you drop onto your animation from your file 

system, are embedded exactly as is. 

 

256 color or less bitmaps (such as GIF) are not encoded as JPEG and will be 

embedded using PNG compression, which is usually the best compression type for 

these types of images 

 

Bitmap quality 
Flash Player version 8 and later has higher quality bitmap display. This is particular 

evident when rotating or scaling bitmaps and photos whereas older versions of the 

player tend to produce pixelated, and rather jerky movements. 

 

]©ĉ¨4©|y§yz¤§y4§yw¤¢¢y£xyx4©¤4y­¥¤§©4®¤ª§4Z¡u¨|4u£}¢u©}¤£4u¨4jy§¨}¤£4L4}z4®¤ªĉ§y4

using bitmaps or photos. You can control this from the Flash Options tab of the 

Animation Properties dialog. 

 

You can tell which 

version of the 

Flash Player you 

have by right 

clicking on any 

Flash animation in 

your web browser 

and looking at the 

About menu. 
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Animation frame rate and tween steps 

Flash animations run at a fixed frame rate. The faster the frame rate the smoother 

the resulting animation, and the larger the Flash file. Xtreme animations default to 

showing 24 frames per second but you can change this. 

  

When you create each key frame you determine how long the period is until the 

next key frame. For example if a frame period is set to half a second, this means the 

animation from that key frame to the next will take half a second. At 24 frames per 

second this means there will be 11 intermediate steps generated by Xtreme in the 

Flash animation, so 12 frames in all. (These intermediate frames are not ever seen in 

Xtreme they are only generated when you create the Flash file.) 

  

 
The Frame gallery always shows you the display period for each key frame. 

In this example three frames are displayed for half a second each, so 

the whole animation lasts 1.5 seconds before repeating. 

 

To create a longer tween effect, in other words to slow the animation down, 

increase the display period using the Animation Properties dialog. 

 

The easiest way to alter the display period for any frame is to just double-click on 

the frame name you want to alter, which brings up the dialog, enter the new period 

in seconds and click OK or Apply. 
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Cropping and clipping 

Before long you'll start to consider creating some Flash animations like you see on 

the web, say with some wording or a photo that whizzes in from one side. 

  

Assuming you want the animation cropped to the frame, how do you do this?  The 

answer is to use ClipViews. (See page 99 of the main manual for help on ClipViews.) 

  

By using a rectangle as a ClipView object it means your animation never strays 

outside the frame. So the half-way point of your animation would look like this: 

 
  

 To create an animation like this: 

1. Create your first frame as before, drawing the rectangle, text and shapes at 

their starting positions (the text and shapes could be entirely outside the 

rectangle frame at the start).  

2. Name the objects you want to animate, in the above case the text and star 

shape.  

3. Make sure the rectangle frame is the back-most object (select the object 

then select Arrange > Put to Back or shortcut Ctrl+B). This is because the 

back-most object is the one that will be used as the clipping shape.  

4. Select all the objects, and select Arrange > Apply ClipView. 

5. Click the Copy Frame button to create your 2nd key frame. 

 
6. Select Arrange > Remove ClipView so you can work on the separate 

objects again.  

7. Adjust the text and star size and position as required.  

8. Select all the objects again, and select Arrange > Apply Clipview. 

9. Press the Preview Flash button to see the animation. 

 
 

Note: if you get a warning telling you that 'non round line joins and end caps' are only 

supported by SWF 8 then you can either ignore it (all line end caps and joins will use 

the round settingąfew people will notice) or set the Flash version to use version 8 

from the Animation Properties dialog (click Properties in the Frame gallery). 

  

Although you can use Select Inside (Ctrl+click) to select objects inside a ClipView, 

it's generally easier to remove the ClipView, edit the frame contents as required and 

then Select All and re-apply the ClipView again. Remember that the ClipView object 

is always the back-most object of the selection. 
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Animation speed 

When you create a new key frame it defaults to having a period of half a second. 

So the animation from that key frame to the next will take half a second. The longer 

you set the period the slower the animation. To set the frame period for any frame, 

first select the desired frame in the Frame gallery (click on it) and then click the 

Animation Properties button (or just double-click the frame name). 

 

 
Setting ĈDisplay This Frame Forĉ to 2 seconds means the animation 

will take 2 seconds before it gets to the next key frame. 

  

Note:  the Animation Properties dialog is non-modal and you can keep this on 

screen all the time. By pressing the Apply button instead of OK, the dialog remains 

on screen. Its contents are updated as you select different frames, and for each of 

them you can set the required display period. 
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Animation smoothness 

Flash movies play at a constant frame rate. The faster the frame rate the smoother 

the animation. Xtreme defaults to showing 24 frames per second. To change the rate 

select the Flash Options tab of the Animation Properties dialog. 

 

 
 The Flash Options tab, where you can change the 

movie speed as well as the Flash export version. 

 

Note:  the faster the frame rate the larger the resulting Flash file. You will find that if 

your animation is mostly objects fading in and out with relatively little fast moving 

animation, then you can reduce the frame rate to under 24 frames per second. If you 

have a lot of fast action it may be necessary to increase the frame rate, but itĉs rarely 

necessary to have it above 50 frames per second. 

  

The default movie speed of 24 frames per second ties into the default frame period 

of half a second. It means that, using these defaults, there are exactly 12 frames of 

the movie from one key-frame to the next. 
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Rotation 

Xtreme calculates and generates the tween frames automatically by working out 

how to transform the shapes from one key frame to the next. But sometimes it's not 

possible to know exactly what type of rotation is required.  

 

Take this example. Suppose you tween from the first clock face to the second: 

 

              
 

You might expect it to rotate clockwise, but of course it could go counter clockwise: 

  

            
 

In fact there are other ways it could rotate. The above examples assume the hand 

rotates around one end, but you could tween from one state into the other by doing 

a straight line rotation of the center of the object, which would result in this: 

 

 
 

If you look closely, the hand rotates around its center rather than one end, and the 

center point moves in the straight line from one key frame to the next. By default, 

Xtreme rotates objects this way. 

 

The Rotate command 
To force the rotation to be around any other point you can use a special keyword 


